Tutorial Drop Port Scanner di Mikrotik

Pengertian Port Scanners

Port scanner adalah adalah sebuah aplikasi yang dirancang untuk mengetahui port yang terbuka pada server atau host, bagi seorang administrator jaringan port scanner sering digunakan untuk memverifikasi keamanan jaringan yang dikelola tapi bagi seorang attacker port scanner justru sebagai tools yang bisa digunakan untuk mengidentifikasi service yang berjalan pada server atau host lalu memanfaatkan port tersebut untuk keperluan eksploitasi.
RouterOS mikrotik memiliki fitur yang bisa kita manfaatkan untuk keperluan drop port scanner ini agar router kita aman dari attacker yang mencoba melakukan port scanning.

Cara Drop Port Scanners di Mikrotik

Setelah mengetahui bahaya dari port scanner ini, sebagai seorang administrator jaringan sebaiknya sobat melakukan filtering untuk menangkal port scanner ini agar router yang sobat kelola bisa lebih aman dari attacker yang tidak bertanggung jawab.

Update !!!
Apabila pada jaringan sobat ada salah satu PC/Laptop yang menginstall software monitoring The Dude, maka IP PC tersebut harus diallow agar tidak terblok oleh rule drop port scanner ini.
Untuk melakukan filtering port scanner pada router mikrotik pun cukup mudah, pertama silahkan login ke mikrotik bisa menggunakan winbox, ssh, ataupun telnet. Kalau sobat login dengan winbox klik menu New Terminal kemudian copy script dibawah di terminal mikrotik sobat :

/ip firewall filter
add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment=\
    "Add TCP Port Scanners to List" protocol=tcp psd=21,3s,3,1

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP FIN Stealth scan" \
    protocol=tcp tcp-flags=fin,!syn,!rst,!psh,!ack,!urg

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP SYN/FIN scan" protocol=\
    tcp tcp-flags=fin,syn

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP SYN/RST scan" protocol=\
    tcp tcp-flags=syn,rst

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP FIN/PSH/URG scan" \
    protocol=tcp tcp-flags=fin,psh,urg,!syn,!rst,!ack

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="ALL/ALL TCP Scan" protocol=\
    tcp tcp-flags=fin,syn,rst,psh,ack,urg

add action=add-src-to-address-list address-list=port_scanners \
    address-list-timeout=2w chain=input comment="TCP NULL scan" protocol=tcp \
    tcp-flags=!fin,!syn,!rst,!psh,!ack,!urg

add action=drop chain=input comment="Drop All Port Scanners" \
    src-address-list=port_scanners

Kalau sudah selesai hasil nya akan seperti ini, apabila ada aktifitas port scanning terhadap router mikrotik sobat maka akan muncul counters traffic dalam hitungan bytes di menu IP ~> Firewall ~> Filter Rules.


Setiap IP attacker yang berusaha melakukan port scanning ke router mikrotik sobat maka otomatis akan masuk ke Address List yang sudah kita tentukan tadi yaitu port_scanner, contoh nya bisa sobat lihat screenshoot dibawah.


Setiap IP attacker yang melakukan port scanning terhadap mikrotik sobat akan masuk ke address list selama 2w (14 hari) dan selanjutnya akan di drop oleh rules yang paling bawah sehingga tidak akan bisa menyerang router mikrotik sobat lagi, tapi bagaimana kalau IP attacker nya sudah tidak dikarantina di address list dan melakukan port scanning lagi ?

Maka akan masuk lagi ke address list dan di drop lagi oleh rules tersebut, begitu dan begitu seterus nya selama sobat tidak melepas filter port scanner nya. Akhir kata semoga tutorial sederhana ini bisa membatu sobat yang sedang galau karena router nya terkena port scanner oleh attacker yang tidak bertanggung jawab. Semoga bermanfaat :-)

Baca juga : Mengenal Service pada Mikrotik

Subscribe to receive free email updates: