Tutorial Konfigurasi Static Routing di Router Mikrotik (Studi Kasus 1)

Tutorial Konfigurasi Static Routing di Mikrotik - Static routing merupakan teknik routing yang dilakukan dengan cara memasukkan entry routing secara manual kedalam tabel routing yang ada didalam router. Didalam tabel routing, kita bisa melihat informasi-informasi berupa network yang dapat dituju oleh router.

Sebetulnya ketika kita menambahkan IP address pada port interface router mikrotik, maka router mikrotik akan membuat entry route secara otomatis, namun entry route yg dibuat secara otomatis tersebut hanyalah entry route untuk network yang terhubung secara langsung dengan router (directly connected).

Sedangkan untuk network yang tidak terhubung secara langsung dengan router (remote network), maka tidak akan dibuatkan entry route secara otomatis, sehingga apabila ingin menghubungkan 2 network yang berbeda atau lebih kita harus memanfaatkan static routing.

Static routing biasanya diimplementasikan didalam network yang skala nya kecil, sedangkan untuk network yang skala besar, penggunaan static routing ini kurang efisien dan sangat merepotkan karena harus menginput entry route satu persatu secara manual.

Pada tutorial ini kita akan belajar bagaimana mengkonfigurasi static routing pada router mikrotik, judul artikel ini saya tambah dengan kalimat Study Kasus 1, ini dikarenakan inspirasi pembuatan artikel ini berawal dari case yang dihadapi oleh teman di forum mikrotik indonesia. Jadi, sang teman memiliki problem ketika ingin menghubungkan client (PC) yang berada dibawah router mikrotik RB-2 (Network A) dengan client yang berada dibawah router mikrotik RB-3 (Network B).

Untuk lebih jelasnya silahkan sobat lihat topology dibawah ini.

Tutorial Konfigurasi Static Routing di Router Mikrotik

Dari topology diatas terdapat 3 buah router mikrotik, yaitu RB-1 sebagai main router, RB-2 dan RB-3. Namun sebelum masuk ke tahap inti yaitu mengkonfigurasi static routing agar client yang berada dibawah RB-2 dan RB-3 dapat saling berkomunikasi, kita harus mengkonfigurasi ketiga router tersebut.
Pada tutorial ini saya menggunakan GNS3 untuk mensimulasikan cara konfigurasinya, tapi tutorial ini dapat diimplementasikan langsung di real device atau perangkat asli, berikut konfigurasi router mikrotik RB-1, RB-2 dan RB-3.

Konfigurasi Router MikroTik (RB-1)
[admin@MikroTik] > /ip address add address=10.10.10.2/24 interface=ether1
[admin@MikroTik] > /ip address add address=192.168.2.1/24 interface=ether2
[admin@MikroTik] > /ip address add address=192.168.3.1/24 interface=ether3
[admin@MikroTik] > /ip route add gateway=10.10.10.1
[admin@MikroTik] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Konfigurasi Router MikroTik (RB-2)
[admin@MikroTik] > /ip address add address=192.168.3.2/24 interface=ether2
[admin@MikroTik] > /ip address add address=192.168.10.1/24 interface=ether3
[admin@MikroTik] > /ip route add gateway=192.168.3.1
[admin@MikroTik] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes  
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade

Konfigurasi Router MikroTik (RB-3)
[admin@MikroTik] > /ip address add address=192.168.2.2/24 interface=ether2
[admin@MikroTik] > /ip address add address=192.168.20.1/24 interface=ether3
[admin@MikroTik] > /ip route add gateway=192.168.2.1
[admin@MikroTik] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether2 action=masquerade 

Setelah selesai mengkonfigurasi ketiga router tersebut, sekarang kita harus mengkonfigurasi IP address, netmask, gateway dan DNS untuk masing-masing PC. Untuk mengkonfigurasi IP address dan lain-lain pada host di GNS3, lakukan remote console ke PC nya kemudian ketikkan perintah berikut.

Konfigurasi PC-1 (Network A)
PC1> ip 192.168.10.2 255.255.255.0 192.168.10.1
PC1> ip dns 8.8.8.8

Konfigurasi PC-2 (Network B)
PC2> ip 192.168.20.2 255.255.255.0 192.168.20.1
PC1> ip dns 8.8.8.8

Sampai disini, konfigurasi dasar untuk menghubungkan antar router dan menghubungkan PC client ke internet sudah selesai, untuk memastikan semuanya sudah berjalan dengan baik, lakukan test ping antar router, test ping dari masing-masing router ke internet maupun test ping dari masing-masing PC client ke internet, seharusnya sudah reply.

Konfigurasi Static Routing 

Sekarang, coba lakukan test ping antar PC, yaitu dari PC-1 ping ke PC-2 dan begitu juga sebaliknya, seharusnya ping antar PC tidak berhasil (Destination network unreachable), lalu bagaimana cara menghubungkan kedua PC yang berbeda network tersebut ? nah, untuk itulah kita perlu menambahkan static routing.

Dengan topology seperti diatas, konfigurasi static routing cukup dilakukan di router utama saja yaitu  router mikrotik RB-1, untuk router RB-2 dan RB-3 tidak perlu ditambahkan static routing.
[admin@MikroTik] > /ip route add dst-address=192.168.10.0/24 gateway=192.168.3.2
[admin@MikroTik] > /ip route add dst-address=192.168.20.0/24 gateway=192.168.2.2  

Konfigurasi diatas berfungsi untuk menunjukkan jalur yang harus ditempuh ketika ingin mengirim sebuah packet data. Misalnya, ketika kita ingin mengirimkan packet ICMP (PING dan Traceroute) dari PC-2 ke PC-1 yang berada didalam network yang berbeda.

Maka secara otomatis packet data tersebut akan melewati router RB-3 dan berakhir di router RB-1, nah dengan adanya entry static routing yang sudah kita buat, maka router 1 (RB-1) akan menunjukkan jalan yang harus ditempuh oleh si packet data tersebut, yaitu untuk menuju ke PC-1 yang berada didalam network 192.168.10.0/24 maka harus melalui  pintu gerbang atau gateway 192.168.3.2 (RB-2), begitu juga sebaliknya.

Untuk memastikan apakah PC-1 dan PC-2 yang berbeda network sudah bisa saling berkomunikasi atau belum, lakukan test ping antar PC, seharusnya hasilnya sudah reply seperti ini.
PC1> ping 192.168.20.2     

84 bytes from 192.168.20.2 icmp_seq=1 ttl=61 time=6.323 ms
84 bytes from 192.168.20.2 icmp_seq=2 ttl=61 time=3.345 ms
84 bytes from 192.168.20.2 icmp_seq=3 ttl=61 time=3.887 ms
84 bytes from 192.168.20.2 icmp_seq=4 ttl=61 time=3.343 ms
84 bytes from 192.168.20.2 icmp_seq=5 ttl=61 time=3.542 ms
PC2> ping 192.168.10.2

84 bytes from 192.168.10.2 icmp_seq=1 ttl=61 time=3.240 ms
84 bytes from 192.168.10.2 icmp_seq=2 ttl=61 time=2.975 ms
84 bytes from 192.168.10.2 icmp_seq=3 ttl=61 time=1.905 ms
84 bytes from 192.168.10.2 icmp_seq=4 ttl=61 time=4.088 ms
84 bytes from 192.168.10.2 icmp_seq=5 ttl=61 time=4.295 ms

Sampai disini, kita sudah berhasil menghubungkan 2 network yang berbeda menggunakan static routing pada router mikrotik, dalam implementasi dilapangan tentu saja topology jaringan yang dihadapi bisa saja berbeda.

Untuk itu, diblog ini saya akan mempublish beberapa artikel / tutorial konfigurasi static routing dengan topology yang berbeda pula, jadi nantinya akan ada studi kasus 2, 3 dan seterusnya.

Terimakasih, semoga bermanfaat 😊


Subscribe to receive free email updates: