Tutorial Konfigurasi Static Routing di Router Mikrotik (Studi Kasus 2)

Tutorial Konfigurasi Static Routing di Router Mikrotik - Masih membahas tentang static routing di router mikrotik, kali ini saya akan membahas konfigurasi static routing pada router mikrotik menggunakan topology yang sangat sederhana. Artikel ini sendiri merupakan lanjutan dari artikel sebelumnya yang sudah saya posting di blog ini.

Diartikel sebelumnya saya sudah membahas tutorial konfigurasi static routing di router mikrotik (studi kasus 1), sesuai janji saya sebelumnya, bahwa pembahasan mengenai konfigurasi static routing pada router mikrotik ini akan ada studi kasus 1, studi kasus 2, studi kasus 3 dan seterusnya.


Sesi studi kasus ini bertujuan untuk memecahkan case yang dihadapi oleh seorang Network Engineer di lapangan, dimana topology yang digunakan tentu saja berbeda-beda, kita akan belajar bagaimana mengkonfigurasi static routing pada router mikrotik baik menggunakan topology yang sederhana maupun topology yang cukup kompleks.

Setiap sesi studi kasus ini sebetulnya tujuan nya masih sama, yaitu bagaimana mengkonfigurasi routing static untuk menghubungkan setiap network yang berbeda segment IP agar dapat saling berkomunikasi, hanya saja, penggunaan topology disetiap sesi nya yang berbeda.

Pada sesi (studi kasus 2) kali ini, kita akan mencoba menghubungkan 2 network yang berbeda dengan dua router mikrotik menggunakan static routing, perlu diketahui, saya menggunakan network simulator GNS3, namun apabila sobat ingin mencoba nya menggunakan real device tentu tidak masalah.

Untuk topology yang digunakan pada sesi (studi kasus 2) kali ini bisa sobat lihat pada gambar dibawah.

Tutorial Konfigurasi Static Routing di Router Mikrotik

Pada gambar topology diatas bisa dilihat bahwa terdapat 2 router mikrotik (R1 dan R2) yang saling terhubung pada port interface ether1 masing-masing router, dan port interface ether2 masing-masing router terhubung ke PC client (local network).

Pada studi kasus ini kita hanya akan belajar mengkonfigurasi kedua router tersebut agar PC client yang berada dibawah masing-masing router dapat terkoneksi satu sama lain tanpa terkoneksi ke internet, ini dikarenakan pada topology diatas hanya ada 2 buah router mikrotik dan 2 PC client tanpa modem.

Sebelum mengkonfigurasi static routing pada kedua router, tentunya kita harus melakukan konfigurasi dasar terlebih dahulu, saya asumsikan sobat sudah mengerti dan paham mengenai konfigurasi dasar router mikrotik karena disini saya tidak akan menjelaskan secara detail mengenai konfigurasi dasarnya.

Baca juga : 

Konfigurasi Router Mikrotik R1
[admin@MikroTik] > /ip address add address=192.168.1.1/24 interface=ether1
[admin@MikroTik] > /ip address add address=192.168.10.1/24 interface=ether2
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

Konfigurasi Router Mikrotik R2
[admin@MikroTik] > /ip address add address=192.168.1.2/24 interface=ether1
[admin@MikroTik] > /ip address add address=192.168.20.1/24 interface=ether2
[admin@MikroTik] > /ip route add gateway=192.168.1.1
[admin@MikroTik] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Sekarang kita harus mengkonfigurasi IP Address untuk masing-masing PC client nya, isikan parameter seperti IP Address, Netmask dan Gateway dengan detail sebagai berikut.

Konfigurasi PC1
  • IP Address = 192.168.10.2
  • Netmask = 255.255.255.0
  • Gateway = 192.168.10.1

Konfigurasi PC2
  • IP Address = 192.168.20.2
  • Netmask = 255.255.255.0
  • Gateway = 192.168.20.1

Kalau menggunakan GNS3, maka perintah untuk mengkonfigurasi IP Address, Netmask dan Gateway pada setiap PC client nya seperti ini.
PC1> ip 192.168.10.2 255.255.255.0 192.168.10.1
PC2> ip 192.168.20.2 255.255.255.0 192.168.20.1

Dengan konfigurasi tersebut, R1 dengan R2 sudah dapat saling berkomunikasi (ping reply), dan PC2 yang berada dibawah R2 sudah berhasil ping reply ke PC1 yang berada dibawah R1. Namun, PC1 yang berada dibawah R1 belum berhasil ping reply ke PC2 yang berada dibawah R2.

Lho kok bisa seperti itu? Bisa! ini dikarenakan pada R2 kita sudah menambahkan gateway dengan parameter Dst. Address 0.0.0.0/0 dan gateway 192.168.1.1 jadi semua IP Address yang berada dibawah/diatas router R1 bisa dijangkau oleh router R2. Untuk lebih jelasnya, mari kita lihat tabel routing dikedua router tersebut.

Table Routing Router Mikrotik R1
[admin@MikroTik] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  192.168.1.0/24     192.168.1.1     ether1                    0
 1 ADC  192.168.10.0/24    192.168.10.1    ether2                    0

Table Routing Router Mikrotik R2
[admin@MikroTik] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  0.0.0.0/0                          192.168.1.1               1
 1 ADC  192.168.1.0/24     192.168.1.2     ether1                    0
 2 ADC  192.168.20.0/24    192.168.20.1    ether2                    0

Dari kedua table routing diatas, bisa dilihat bahwa table routing di router mikrotik R2 sudah lengkap, itulah sebabnya kenapa PC2 sudah berhasil ping reply ke PC1. Namun, PC1 belum berhasil ping reply ke PC2, ini dikarenakan table routing pada router mikrotik R1 belum lengkap, sehingga ketika ada packet data yang akan menuju ke network 192.168.20.0/24 yang merupakan Remote Network dari R1 tidak bisa diteruskan ke tujuan oleh router R1.

Untuk itu kita perlu menambahkan entry route secara manual didalam table routing router R1, entry route ini digunakan sebagai acuan oleh router R1 untuk memetakan rute mana yg harus ditempuh ketika ada packet data yg akan menuju suatu network. Proses menambahkan entry route secara manual ini disebut juga dengan teknik static routing, dimana sang administrator harus menambahkan entry route secara manual kedalam tabel routing pada router.

Konfigurasi static routing pada R1 caranya cukup mudah, kita hanya perlu menambahkan rule baru dengan parameter Dst. Address yaitu diisi dengan IP network yang akan dituju, dan Gateway yaitu IP Address router yang dilewati.
[admin@MikroTik] > /ip route add dst-address=192.168.20.0/24 gateway=192.168.1.2
[admin@MikroTik] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  192.168.1.0/24     192.168.1.1     ether1                    0
 1 ADC  192.168.10.0/24    192.168.10.1    ether2                    0
 2 A S  192.168.20.0/24                    192.168.1.2               1

Sekarang coba sobat test ping dari PC1 ke IP Address PC2, seharusnya sudah berhasil mendapatkan ping reply. Apabila sudah berhasil ping reply berarti konfigurasi static routing di kedua router berjalan dengan baik.

Jangan lupa share artikel ini jika dirasa bermanfaat, apabila ada penjelasan yang belum sobat pahami, jangan sungkan untuk bertanya dikolom komentar ya 😉

Terimakasih & semoga bermanfaat.


Subscribe to receive free email updates: