Tutorial Konfigurasi Static Routing di Router Mikrotik (Studi Kasus 3)

Tutorial Konfigurasi Static Routing di Router Mikrotik - Artikel ini merupakan lanjutan dari artikel sebelumnya yaitu studi kasus 1 dan studi kasus 2 yang sudah saya publish beberapa waktu lalu di blog ini, pada studi-studi kasus sebelumnya kita sudah belajar bagaimana mengkonfigurasi static routing pada router mikrotik menggunakan topologi yang sederhana, yaitu menggabungkan 2 network yang berbeda.

Baca juga :
Tutorial konfigurasi static routing di router mikrotik (studi kasus 1)
Nah, pada kesempatan kali ini, saya akan mengajak sobat untuk belajar bagaimana cara mengkonfigurasi static routing pada router mikrotik dengan topology yang lebih kompleks, dimana kita akan belajar menghubungkan 5 router mikrotik yaitu 1 router (R1) berfungsi sebagai core router dan 4 router lainnya (R2, R3, R4 dan R5) berfungsi sebagai router distribusi.

Empat router lain yang berfungsi sebagai router distribusi (R2, R3, R4, R5) tentu saja masing-masing mempunyai local network (LAN) yang berbeda satu sama lain. Tugas kita adalah bagaimana caranya agar setiap router dapat saling berkomunikasi dan masing-masing local network (yaitu PC1, PC2, PC3 dan PC4 dalam studi kasus ini) juga dapat saling berkomunikasi. Sebagai gambaran, sobat bisa melihat topology yang digunakan pada studi kasus kali ini pada gambar dibawah.

Tutorial Konfigurasi Static Routing di Router Mikrotik

Dari topology diatas bisa dilihat bahwa terdapat satu router yaitu R1 yang langsung terhubung ke modem (ISP) di port ether1, sedangkan ether2 dan ether3 terhubung ke router dibawahnya yang berfungsi sebagai router distribusi, untuk menghubungkan semua router dan local network dibawah masing-masing router seperti topology diatas, kita bisa menyelesaikan nya dengan konfigurasi static routing, namun sebelum masuk ke tahap konfigurasi static routing, kita harus melakukan konfigurasi dasar untuk semua router dan PC Client yang ada. 

Untuk lebih jelasnya, berikut skema pengalokasian IP Address untuk masing-masing device.

Table Addressing

Device Interface IP Address Netmask Default Gateway
R1 ether1 10.10.10.2 255.255.255.0 10.10.10.1
ether2 192.168.2.1 255.255.255.0 N/A
ether3 192.168.3.1 255.255.255.0 N/A
R2 ether1 192.168.2.2 255.255.255.0 192.168.2.1
ether2 192.168.4.1 255.255.255.0 N/A
ether3 192.168.10.1 255.255.255.0 N/A
R3 ether1 192.168.3.2 255.255.255.0 192.168.3.1
ether2 192.168.5.1 255.255.255.0 N/A
ether3 192.168.30.1 255.255.255.0 N/A
R4 ether1 192.168.4.2 255.255.255.0 192.168.4.1
ether2 192.168.40.1 255.255.255.0 N/A
R5 ether1 192.168.5.2 255.255.255.0 192.168.5.1
ether2 192.168.50.1 255.255.255.0 N/A

Dikarenakan saya tidak memiliki router dan PC sebanyak itu, maka untuk mensimulasikan nya saya menggunakan network simulator GNS3 yang sudah terinstall di laptop, untuk proses belajar sobat bisa menggunakan network simulator GNS3 seperti yang saya gunakan atau menggunakan real device secara langsung.

Baiklah, saya kira sudah cukup basa basinya, mari kita langsung saja ke tahap konfigurasi, saya anggap sobat sudah paham konfigurasi dasar router mikrotik karena disini saya tidak akan menjelaskan secara detail fungsi dari setiap perintah yang digunakan.


Konfigurasi di router R1
[admin@R1] > /ip address add address=10.10.10.2/24 interface=ether1 comment="WAN"
[admin@R1] > /ip address add address=192.168.2.1/24 interface=ether2 comment="Link to R2"
[admin@R1] > /ip address add address=192.168.3.1/24 interface=ether3 comment="Link to R3"
[admin@R1] > /ip route add gateway=10.10.10.1
[admin@R1] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@R1] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Konfigurasi di router R2
[admin@R2] > /ip address add address=192.168.2.2/24 interface=ether1 comment="Link from R1"
[admin@R2] > /ip address add address=192.168.4.1/24 interface=ether2 comment="Link to R4"
[admin@R2] > /ip address add address=192.168.10.1/24 interface=ether3 comment="Local LAN"    
[admin@R2] > /ip route add gateway=192.168.2.1 
[admin@R2] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@R2] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Konfigurasi di router R3
[admin@R3] > /ip address add address=192.168.3.2/24 interface=ether1 comment="Link from R1"
[admin@R3] > /ip address add address=192.168.5.1/24 interface=ether2 comment="Link to R5"
[admin@R3] > /ip address add address=192.168.30.1/24 interface=ether3 comment="Local LAN"
[admin@R3] > /ip route add gateway=192.168.3.1
[admin@R3] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@R3] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade 

Konfigurasi di router R4
[admin@R4] > /ip address add address=192.168.4.2/24 interface=ether1 comment="Link from R2"
[admin@R4] > /ip address add address=192.168.40.1/24 interface=ether2 comment="Local LAN"
[admin@R4] > /ip route add gateway=192.168.4.1
[admin@R4] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@R4] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

Konfigurasi di router R5
[admin@R5] > /ip address add address=192.168.5.2/24 interface=ether1 comment="Link from R3"
[admin@R5] > /ip address add address=192.168.50.1/24 interface=ether2 comment="Local LAN"
[admin@R5] > /ip route add gateway=192.168.5.1
[admin@R5] > /ip dns set servers=8.8.8.8,8.8.4.4 allow-remote-requests=yes 
[admin@R5] > /ip firewall nat add chain=srcnat out-interface=ether1 action=masquerade

Selanjutnya kita harus mengkonfigurasi IP address pada setiap PC client yang berada dibawah masing-masing router, untuk alokasi IP Address yang digunakan silahkan sobat lihat kembali Table Addressing diatas.

Konfigurasi di PC1
PC1> ip 192.168.10.2 255.255.255.0 192.168.10.1
PC1> ip dns 8.8.8.8

Konfigurasi di PC2
PC2> ip 192.168.30.2 255.255.255.0 192.168.30.1 
PC2> ip dns 8.8.8.8

Konfigurasi di PC3
PC3> ip 192.168.40.2 255.255.255.0 192.168.40.1
PC3> ip dns 8.8.8.8

Konfigurasi di PC4
PC4> ip 192.168.50.2 255.255.255.0 192.168.50.1
PC4> ip dns 8.8.8.8

Dengan konfigurasi tersebut, maka semua router distribusi baik itu router R2, R3, R4 maupun R5 sudah berhasil ping reply ke core router yaitu router R1 dan sudah berhasil terkoneksi ke internet, namun permasalahan nya adalah.
  • Router R1 hanya bisa ping reply ke router R2 dan R3
  • Router R2 hanya bisa ping reply ke router R1, R3, dan R4 
  • Router R3 hanya bisa ping reply ke router R1, R2, dan R5
  • Router R4 hanya bisa ping reply ke router R2, R1, dan R3
  • Router R5 hanya bisa ping reply ke router R3, R1, dan R2

Padahal, kita ingin menghubungkan semua router dan semua local network yang berada dibawah masing-masing router agar dapat saling berkomunikasi satu sama lain. Untuk itu kita perlu menambahkan konfigurasi static routing agar semua nya dapat saling terkoneksi dengan baik.

Untuk menghubungkan semua router beserta local network nya, kita hanya perlu menambahkan entry route secara manual pada router R1, R3 dan R3. Jadi tidak perlu menambahkan konfigurasi static routing di semua router.

Konfigurasi static routing di R2
[admin@R1] > /ip route add dst-address=192.168.10.0/24 gateway=192.168.2.2
[admin@R1] > /ip route add dst-address=192.168.4.0/24 gateway=192.168.2.2
[admin@R1] > /ip route add dst-address=192.168.30.0/24 gateway=192.168.3.2
[admin@R1] > /ip route add dst-address=192.168.5.0/24 gateway=192.168.3.2
[admin@R1] > /ip route add dst-address=192.168.40.0/24 gateway=192.168.2.2
[admin@R1] > /ip route add dst-address=192.168.50.0/24 gateway=192.168.3.2

Konfigurasi static routing di R2
[admin@R2] > /ip route add dst-address=192.168.40.0/24 gateway=192.168.4.2

Konfigurasi static routing di R3
[admin@R3] > /ip route add dst-address=192.168.50.0/24 gateway=192.168.5.2

Selesai, dengan begitu, semua router dan semua PC client yang berada dibawah masing-masing router sudah dapat saling berkomunikasi, untuk pengujian silahkan sobat lakukan test ping dari masing-masing PC, apabila berhasil mendapatkan ping reply, berarti konfigurasinya sudah betul. Namun apabila belum ping reply coba di crosschek lagi, pastikan tidak ada konfigurasi yang terlewat.

Mohon maaf apabila ada kekurangan, kalau ada penjelasan yang susah dimengerti, jangan sungkan untuk bertanya dikolom komentar ya sob, terimakasih semoga bermanfaat. 😊


Subscribe to receive free email updates: