Tutorial Bypass Traffic Lokal Pada Jaringan LAN Mikrotik

Tutorial Bypass Traffic Lokal Pada Jaringan LAN Mikrotik - Masih membahas tutorial seputar QoS (Quality of Service) atau bahasa sederhananya adalah management bandwidth, nah pada artikel kali ini saya akan membahas bagaimana memisahkan bandwidth atau traffic internet dan traffic lokal.

Tujuannya adalah agar traffic ke situs-situs internet untuk keperluan seperti browsing, streaming, chatting dan lain-lain bisa terlimit oleh router mikrotik, sedangkan traffic antar client yang sama-sama berada di jaringan lokal tidak terlimit oleh router. 

Study Kasus

Contoh didalam sebuah jaringan terdapat 1 buah router yang berfungsi sebagai internet gateway dengan kondisi sebagai berikut.

Interface IP Address Keterangan
ether1 172.20.19.2/30 Terhubung ke modem ISP (WAN)
ether2 192.168.10.1/24 Terhubung ke PC Server (LAN)
ether3 192.168.12.1/24 Terhubung ke Switch (LAN)
Untuk lebih jelasnya sobat bisa melihat alokasi alamat IP seperti pada contoh topology dibawah.

Tutorial Bypass Traffic Lokal Pada Jaringan LAN Mikrotik

Dari contoh topology diatas bisa dilihat bahwa terdapat 1 PC Server dengan alamat IP 192.168.10.2 yang nantinya akan diakses oleh banyak user yang berada didalam network 192.168.12.0/24.

Pada skenario ini PC Server digunakan untuk menyimpan file, dimana user bisa mengunduh maupun mengunggah file apa saja ke Server tersebut. Sedangkan untuk penerapan dilapangan tentu saja bisa berbeda, entah itu server UNBK, server Accurate, server ERP, server email maupun yang lainnya.

Sementara alokasi bandwidth yang tersedia hanya sebesar 2 Mbps (Megabits / second) untuk semua user, bisa sobat banyangkan apabila alokasi bandwidth sebesar itu habis oleh user yang sedang mengakses internet, maka user yang mengakses sumber daya lokal (PC Server) tidak akan mendapatkan jatah bandwidth yang akan berakibat lambatnya koneksi ke Server tersebut.

Agar traffic antar PC yang sama-sama berada dijaringan lokal (dalam hal ini koneksi dari user / client ke Server) tidak terlimit oleh router mikrotik, maka kita perlu menambahkan konfigurasi khusus untuk mendefinisikan mana traffic lokal dan mana traffic ke internet menggunakan fitur mangle.

Konfigurasi mangle untuk memisahkan traffic internet & traffic lokal

Untuk membuat rule mangle, silahkan login ke router mikrotik via winbox, klik menu New Terminal, lalu copy paste perintah berikut di New Terminal mikrotik.

/ip firewall mangle
add chain=prerouting src-address=192.168.12.0/24 dst-address=!192.168.10.2 action=mark-connection new-connection-mark=Bypass-LAN passthrough=yes comment="Bypass Traffic Lokal"
add chain=prerouting connection-mark=Bypass-LAN action=mark-packet new-packet-mark=Bypass-LAN passthrough=no

Maksud dari rule mangle diatas yaitu ketika ada traffic koneksi yang berasal dari network 192.168.12.0/24 dengan tujuan BUKAN (ditandai dengan "!" yang berarti NOT) alamat IP 192.168.10.2 maka oleh router akan ditandai sebagai traffic ke internet.

Sedangkan apabila koneksi yg berasal dari network 192.168.12.0/24 dengan tujuan alamat IP 192.168.10.2 maka akan dikategorikan sebagai traffic lokal.

Pada skenario ini saya mengkombinasikan fitur mangle dengan Queue Simple karena limitasi bandwidth yang ada dirouter saya menggunakan Queue Simple.

Klik menu Queues, kemudian pada tab Simple Queues klik tombol (+) untuk membuat rule baru, lalu isi parameter-parameter berikut.

Name : Bypass Traffic LAN (optional)
Target : 192.168.12.0/24 (isi dengan IP atau network user yang akan dilimit)
Max Limit up/down : Isi sesuai dengan jumlah bandwidth yg akan dialokasikan

Klik tombol Apply untuk menerapkan konfigurasi.

Tutorial Bypass Traffic Lokal Pada Jaringan LAN Mikrotik

Beralih ke tab Advanced, disini untuk Packet Marks nya harus diarahkan ke packet mark yang sudah dibuat pada menu mangle seperti pada tahap sebelumnya, tujuannya agar rule simple queue ini bisa membaca semua kebijakan-kebijakan yang sudah kita terapkan pada mangle.

Kalau sudah, klik tombol Apply lalu OK.

Tutorial Bypass Traffic Lokal Pada Jaringan LAN Mikrotik

Sampai disini semua konfigurasi telah selesai dilakukan dan kita sudah berhasil memisahkan traffic lokal dan traffic ke internet. Dengan begitu, maka lalu lintas data dari/dan ke Server lokal tidak akan terganggu sama sekali sekalipun alokasi bandwidth yang ada sedang penuh.

Baca juga : Cara membuat simple queue mikrotik secara otomatis menggunakan script

Demikian artikel kali ini, semoga bisa bermanfaat bagi kita semua, terimakasih sudah membaca.


Subscribe to receive free email updates: