Tutorial Konfigurasi Redistribute Static Routing Pada RIP (Router Mikrotik)

Redistribute Static Routing Pada Routing RIP - Di artikel sebelumnya saya sudah membahas tutorial mengenai cara konfigurasi dynamic routing RIP (Routing Information Protocol) pada router mikrotik, tujuannya untuk menghubungkan 2 network atau lebih yang berbeda agar dapat saling berkomunikasi.
Penggunaan teknik routing tidak bisa dilepaskan dalam sebuah jaringan. Hal ini sangat wajar mengingat fungsi routing-lah yang membuat sebuah jaringan bisa terbentuk, tidak ada jaringan komputer yang dapat berjalan tanpa adanya routing.

Dengan routing, kita bisa menghubungkan suatu host ke jaringan internet maupun menghubungkan host yang satu dengan host lainnya. Teknik routing yang bisa dipakai pun cukup beragam, ada static routing dan juga dynamic routing.

Static routing cocok diterapkan pada jaringan yang skalanya kecil, namun pada jaringan yang skalanya menengah hingga besar, penggunaan teknik static routing kurang cocok karena kita sebagai admin jaringan akan kerepotan menentukan entri routing secara manual, untuk itu sebaiknya gunakanlah teknik dynamic routing, dimana dengan teknik dynamic routing router akan menentukan dan membuat entri routingnya secara otomatis ke dalam tabel routing.

Baca juga : Tutorial konfigurasi static routing pada router mikrotik

Namun adakalanya sebuah jaringan menerapkan lebih dari 1 teknik routing, misalnya pada sebuah kantor terdapat 2 divisi yang berbeda yang menggunakan teknik routing berbeda pula, contoh divisi IT menggunakan dynamic routing RIP dan divisi Marketing menggunakan teknik static routing.

Agar kedua jaringan yang berbeda teknik routing dapat bertukar informasi routing update, maka diperlukan konfigurasi Redistribute, dalam studi kasus ini berarti kita akan me-redistribute static routing ke dalam routing RIP.

Coba perhatikan gambar topology di bawah. Bisa dilihat bahwa terdapat 3 router mikrotik, dimana router R1 menjalankan routing RIP, router R2 menjalankan static routing, dan router GW menjalankan keduanya (Static Routing dan RIP).

Tutorial Konfigurasi Redistribute Static Routing Pada RIP (Router Mikrotik)

Dari gambar topologi di atas, karena yang menjalankan routing RIP hanya router R1 dan GW, maka router R1 hanya akan bertukar informasi routing update dengan router GW saja, sehingga router R1 hanya mengetahui network 10.10.10.4/30.

Sedangkan router GW dapat mengetahui dan menjangkau semua network, baik network 192.168.1.0/24, 192.168.2.0/24 yang ada di bawah router R1, maupun network 192.168.3.0/24 dan 192.168.4.0/24 yang ada di bawah router R2. Ini karena router GW menjalankan kedua teknik routing sekaligus (Static Routing dan RIP). 

Tanpa konfigurasi redistribute, maka router R3 juga tidak dapat menjangkau network yang ada di bawah router R1 sekalipun sudah dibuatkan entri routing static untuk menuju ke network tersebut.

Agar router R1 dapat mengetahui network yang ada di bawah router R2 dan sebaliknya, maka kita perlu mengkonfigurasi redistribute static routing pada router GW, namun disini saya tidak hanya menjelaskan konfigurasi redistribute-nya saja, melainkan konfigurasi secara keseluruhan.

Konfigurasi Redistribute Static Routing Dengan RIP

Pertama, kita harus menghubungkan ketiga router dengan cara menambahkan IP Address pada masing-masing interface router.

Konfigurasi IP address router GW

[admin@GW] > /ip address add address=10.10.10.1/30 interface=ether2
[admin@GW] > /ip address add address=10.10.10.5/30 interface=ether3

Konfigurasi IP address router R1

[admin@R1] > /ip address add address=10.10.10.2/30 interface=ether1
[admin@R1] > /ip address add address=192.168.1.1/24 interface=ether2
[admin@R1] > /ip address add address=192.168.2.1/24 interface=ether3

Konfigurasi IP address router R2

[admin@R2] > /ip address add address=10.10.10.6/30 interface=ether1
[admin@R2] > /ip address add address=192.168.3.1/24 interface=ether3
[admin@R2] > /ip address add address=192.168.4.1/24 interface=ether2

Konfigurasi Routing RIP di Router GW dan Router R1

Kemudian kita konfigurasi routing RIP pada router R1 dan router GW agar keduanya dapat bertukar informasi routing update melalui RIP. Disini saya tidak akan menjelaskan secara detail mengenai routing RIP (hanya konfigurasinya saja).

Konfigurasi routing RIP router GW

[admin@GW] > /routing rip interface add interface=ether2 send=v2 receive=v2
[admin@GW] > /routing rip network add network=10.10.10.0/30

Konfigurasi routing RIP router R1

[admin@R1] > /routing rip interface add interface=ether1 send=v2 receive=v2
[admin@R1] > /routing rip network add network=10.10.10.0/30
[admin@R1] > /routing rip network add network=192.168.1.0/24
[admin@R1] > /routing rip network add network=192.168.2.0/24 

Konfigurasi Static Routing di Router GW dan Router R2

Setelah itu lakukan konfigurasi static routing pada router GW dan juga router R2.

Konfigurasi static routing router GW

[admin@GW] > /ip route add dst-address=192.168.3.0/24 gateway=10.10.10.6 
[admin@GW] > /ip route add dst-address=192.168.4.0/24 gateway=10.10.10.6

Konfigurasi static routing router R2

[admin@R2] > /ip route add dst-address=10.10.10.0/30 gateway=10.10.10.5
[admin@R2] > /ip route add dst-address=192.168.1.0/24 gateway=10.10.10.5
[admin@R2] > /ip route add dst-address=192.168.2.0/24 gateway=10.10.10.5

Setelah konfigurasi selesai, berikut tabel routing yang ada di ketiga router (router R1, router GW, dan router R2).

Tabel routing router R1

[admin@R1] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.2      ether1                    0
 1 ADC  192.168.1.0/24     192.168.1.1     ether2                    0
 2 ADC  192.168.2.0/24     192.168.2.1     ether3                    0            1            1 
Dari tabel routing R1 di atas, bisa dilihat bahwa router R1 tidak memiliki entri routing untuk menuju network 10.10.10.4/30, 192.168.3.0/24 dan network 192.168.4.0/24. Dengan begitu, maka router R1 tidak dapat mencapai ketiga network tersebut.

Tabel routing router GW

[admin@GW] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.1      ether2                    0
 1 ADC  10.10.10.4/30      10.10.10.5      ether3                    0
 2 ADr  192.168.1.0/24                     10.10.10.2              120
 3 ADr  192.168.2.0/24                     10.10.10.2              120
 4 A S  192.168.3.0/24                     10.10.10.6                1
 5 A S  192.168.4.0/24                     10.10.10.6          

Selanjutnya coba perhatikan tabel routing pada router GW, karena router GW terhubung dengan R1 dan R2 sekaligus menjalankan static routing dan juga RIP, maka tabel routingnya sudah lengkap, router GW sudah mengetahui keberadaan network yang ada di bawah router R1 dan R2.

Tabel routing router R2

[admin@R2] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 A S  10.10.10.0/30                      10.10.10.5                1
 1 ADC  10.10.10.4/30      10.10.10.6      ether1                    0
 2 A S  192.168.1.0/24                     10.10.10.5                1
 3 A S  192.168.2.0/24                     10.10.10.5                1
 4 ADC  192.168.3.0/24     192.168.3.1     ether3                    0
 5 ADC  192.168.4.0/24     192.168.4.1     ether2                    0          

Begitu juga dengan router R2 yang sudah mengetahui keberadaan network yang berada di bawah router R1 (tabel routingnya sudah lengkap), tapi meskipun tabel routing di router R2 sudah lengkap, router R2 belum bisa menjangkau network yang ada di bawah router R1, ini karena kita belum mengkonfigurasi redistribute static route-nya di router GW.

Agar network yang berada di bawah router R1 dan R2 dapat saling berkomunikasi, maka kita harus mengaktifkan redistribute static route-nya pada router GW.

[admin@GW] > /routing rip set redistribute-static=yes 
[admin@GW] > /routing rip print 
      distribute-default: never
     redistribute-static: yes
  redistribute-connected: no
       redistribute-ospf: no
        redistribute-bgp: no
          metric-default: 1
           metric-static: 1
        metric-connected: 1
             metric-ospf: 1
              metric-bgp: 1
            update-timer: 30s
           timeout-timer: 3m
           garbage-timer: 2m
           routing-table: main

Konfigurasi redistribute static route cukup dilakukan pada router GW saja, untuk router R1 tidak perlu dikonfigurasi. Kemudian kita cek kembali tabel routing pada router R1.

[admin@R1] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.2      ether1                    0
 1 ADC  192.168.1.0/24     192.168.1.1     ether2                    0
 2 ADC  192.168.2.0/24     192.168.2.1     ether3                    0
 3 ADr  192.168.3.0/24                     10.10.10.1              120
 4 ADr  192.168.4.0/24                     10.10.10.1              120

Sekarang tabel routing yang ada di router R1 sudah lengkap, dan R1 sudah mengetahui keberadaan network yang ada di bawah router R2, dengan begitu network yang ada di bawah router R1 dan R2 sudah dapat saling berkomunikasi.

Sampai disini kita sudah berhasil melakukan konfigurasi redistribute static routing pada RIP, dan kedua network yang berbeda teknik routing sudah bisa terhubung dengan baik.

Selamat mencoba!

Berlangganan update artikel terbaru via email:

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel