Tutorial Konfigurasi Routing OSPF Single Area Pada Router Mikrotik

Tutorial Konfigurasi Routing OSPF Single Area Pada Router Mikrotik - OSPF (Open Shortest Path First) merupakan salah satu protocol routing dynamic yang termasuk ke dalam kategori IGP (Interior Gateway Protocol), OSPF adalah routing protocol link state yang memiliki kemampuan lebih baik dibandingkan routing protocol distance vector seperti RIP.
Untuk menentukan jalur terbaik (best path), OSPF menggunakan algoritma djikstra dan cost sebagai metric, dimana link dengan cost terkecil akan dijadikan sebagai best path. OSPF juga tidak memiliki keterbatasan hop count seperti routing RIP (maximum 15 hop), sehingga routing OSPF cocok diterapkan pada jaringan dengan skala menengah hingga besar.

Di dalam routing OSPF dikenal istilah Autonomous System (AS), yaitu sekumpulan router yang menggunakan metode routing yang sama dan masih dalam kendali seorang Administrator, itulah sebabnya OSPF disebut sebagai IGP yang berarti routing protocol ini dipakai untuk menghubungkan jaringan yang masih dalam satu autonomous system yang sama.

Dalam jaringan yang berskala besar, routing OSPF dapat menggunakan konsep hirarki routing, yang diwujudkan dengan pembagian area pada jaringan, konsep ini diterapkan pada teknik routing OSPF Multi Area, dimana kita sebagai administrator dapat membagi jaringan menjadi beberapa area yang lebih kecil, namun untuk menerapkan teknik routing OSPF Multi Area dibutuhkan pemahaman routing yang baik.

Untuk itu, sebelum kita belajar mengkonfigurasi routing OSPF Multi Area, kita harus belajar mengkonfigurasi routing OSPF Single Area terlebih dahulu. Baiklah, agar tutorial ini tidak terlalu teoritis, sebaiknya kita langsung ke intinya saja.

Cara Konfigurasi Routing OSPF Single Area Pada Mikrotik

Pada artikel tutorial mikrotik kali ini kita akan belajar bagaimana cara melakukan konfigurasi routing OSPF single area pada router mikrotik. Topologi yang saya gunakan pada tutorial kali ini masih sama dengan topologi yang saya gunakan pada tutorial konfigurasi redistribute static route pada routing RIP yang sudah saya posting sebelumnya.

Dalam study kasus kali ini saya analogikan dalam sebuah gedung terdapat 2 kantor yaitu Kantor A dan Kantor B, kantor A dihandle oleh satu router mikrotik yaitu router R1, begitu juga dengan kantor B yang dihandle oleh satu buah router mikrotik R2.

Kedua router (R1 & R2) terhubung ke router GW sebagai gateway, router R1 di kantor A memiliki 2 network untuk end user yaitu network 192.168.1.0/24 dan 192.168.2.0/24 yang dihubungkan oleh network 10.10.10.0/30. Sedangkan router R2 di kantor B dihubungkan oleh network 10.10.10.4/30 dan memiliki dua buah network yaitu 192.168.3.0/24 dan 192.168.4.0/24 untuk end user.

Tugas kita adalah menghubungkan semua network yang ada agar dapat saling berkomunikasi baik dari network kantor A ke network kantor B maupun sebaliknya, tentu saja menggunakan OSPF sebagai teknik routingnya.

Tutorial Konfigurasi Routing OSPF Single Area Pada Router Mikrotik

Topologi di atas saya buat dan simulasikan dengan software GNS3, jadi sobat harus menginstalnya dulu, kalau belum silahkan ikuti panduan cara instalasinya disini (Tutorial cara install GNS3).

Lanjut ..

Sebelum melakukan konfigurasi routing OSPF, kita harus mengkonfigurasi IP Address pada interface masing-masing router dengan cara berikut.

Router GW
[admin@GW] > /ip address add address=10.10.10.1/30 interface=ether2
[admin@GW] > /ip address add address=10.10.10.5/30 interface=ether3

Router R1
[admin@R1] > /ip address add address=10.10.10.2/30 interface=ether1
[admin@R1] > /ip address add address=192.168.1.1/24 interface=ether2
[admin@R1] > /ip address add address=192.168.2.1/24 interface=ether3

Router R2
[admin@R2] > /ip address add address=10.10.10.6/30 interface=ether1
[admin@R2] > /ip address add address=192.168.3.1/24 interface=ether3
[admin@R2] > /ip address add address=192.168.4.1/24 interface=ether2

Kemudian aktifkan protocol routing OPSF pada interface masing-masing router, perlu diketahui, tidak semua interface router diaktifkan OSPFnya, hanya interface yang menghubungkan antar router saja.

Router GW
[admin@GW] > /routing ospf interface add interface=ether2
[admin@GW] > /routing ospf interface add interface=ether3

Router R1
[admin@R1] > /routing ospf interface add interface=ether1

Router R2
[admin@R2] > /routing ospf interface add interface=ether1

Setelah mengaktifkan protocol routing OSPF pada masing-masing interface router, hal selanjutnya yang perlu dilakukan yaitu mengkonfigurasi Router ID, Router ID ini sangat penting dalam proses penentuan DR (Designed Router) maupun BDR (Backup Designed Router).

Format penulisan Router ID sama halnya dengan format penulisan IP Address, jika tidak ditentukan secara manual maka router akan menggunakan salah satu IP Address yang ada pada interface router, jika terdapat beberapa IP Address pada interface router, maka router akan mengambil IP Address dengan nilai tertinggi sebagai Router ID-nya.

Router GW
[admin@GW] > /routing ospf instance set default router-id=10.3.3.3 

Router R1
[admin@R1] > /routing ospf instance set default router-id=10.1.1.1

Router R2
[admin@R2] > /routing ospf instance set default router-id=10.2.2.2

Terakhir yaitu meng-advertise network ke dalam routing OSPF, tujuannya yaitu untuk mengenalkan network yang ada pada sebuah router agar dikenali oleh router / network lain melalui proses pertukaran routing update.

Network pada masing-masing router kita advertise ke area 0 atau area backbone, ini karena kita menerapkan routing OSPF Single Area sehingga network yang ada dianggap berada dalam satu area yang sama yaitu area backbone.

Router GW
[admin@GW] > /routing ospf network add network=10.10.10.0/30 area=backbone 
[admin@GW] > /routing ospf network add network=10.10.10.4/30 area=backbone 

Router R1
[admin@R1] > /routing ospf network add network=10.10.10.0/30 area=backbone 
[admin@R1] > /routing ospf network add network=192.168.1.0/24 area=backbone 
[admin@R1] > /routing ospf network add network=192.168.2.0/24 area=backbone 

Router R2
[admin@R2] > /routing ospf network add network=10.10.10.4/30 area=backbone 
[admin@R2] > /routing ospf network add network=192.168.3.0/24 area=backbone 
[admin@R2] > /routing ospf network add network=192.168.4.0/24 area=backbone 

Sampai disini kita sudah berhasil mengkonfigurasi routing OSPF Single Area pada router mikrotik, untuk memastikan router-router yang ada sudah berhasil mencapai kondisi convergence, kita bisa mengecek tabel routing pada masing-masing router.

Router GW
[admin@GW] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.1      ether2                    0
 1 ADC  10.10.10.4/30      10.10.10.5      ether3                    0
 2 ADo  192.168.1.0/24                     10.10.10.2              110
 3 ADo  192.168.2.0/24                     10.10.10.2              110
 4 ADo  192.168.3.0/24                     10.10.10.6              110
 5 ADo  192.168.4.0/24                     10.10.10.6              110

Router R1
[admin@R1] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.2      ether1                    0
 1 ADo  10.10.10.4/30                      10.10.10.1              110
 2 ADC  192.168.1.0/24     192.168.1.1     ether2                    0
 3 ADC  192.168.2.0/24     192.168.2.1     ether3                    0
 4 ADo  192.168.3.0/24                     10.10.10.1              110
 5 ADo  192.168.4.0/24                     10.10.10.1              110

Router R2
[admin@R2] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, C - connect, S - static, 
r - rip, b - bgp, o - ospf, m - mme, B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADo  10.10.10.0/30                      10.10.10.5              110
 1 ADC  10.10.10.4/30      10.10.10.6      ether1                    0
 2 ADo  192.168.1.0/24                     10.10.10.5              110
 3 ADo  192.168.2.0/24                     10.10.10.5              110
 4 ADC  192.168.3.0/24     192.168.3.1     ether3                    0
 5 ADC  192.168.4.0/24     192.168.4.1     ether2                    0

Dari masing-masing tabel routing di atas bisa kita lihat bahwa sudah terdapat entri routing dengan flag ADo yang menandakan bahwa entri routing tersebut statusnya aktif dan dibuat secara dynamic melalui routing OSPF.

Coba lakukan test ping dari masing-masing PC yang berada di bawah router R1 dan R2, jika ternyata berhasil mendapatkan ping reply, berarti kedua network yang ada di Kantor A dan Kantor B sudah terkoneksi melalui routing OSPF.

Demikian tutorial Cara konfigurasi routing OSPF pada router mikrotik, semoga apa yang saya sampaikan melalui tulisan ini bisa bermanfaat untuk kita semua, kalau ada yang kurang mengerti bisa ditanyakan melalui kolom komentar.

Terima kasih.

Berlangganan update artikel terbaru via email:

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel