Tutorial Konfigurasi Routing RIP Pada Router Mikrotik

Tutorial Konfigurasi Routing RIP Pada Router Mikrotik - RIP (Routing Information Protocol) merupakan salah satu jenis routing protocol yang termasuk ke dalam kategori IGP (Interior Gateway Protocol) yaitu routing protocol yang digunakan dalam satu Autonomous System yang sama.

Dalam implementasinya, RIP menggunakan algoritma Distance Vector, yaitu sebuah algoritma yang hanya melihat arah dan jarak untuk mencapai network tujuan. Selain itu, RIP juga menggunakan hop count sebagai metricnya, yaitu banyaknya jumlah jaringan yang akan dilewati ketika hendak menuju network tujuan.

Link dengan hop count terkecil adalah link yang akan dijadikan sebagai jalur terbaik (best path) untuk mencapai network tujuan, ini berguna jika router yang menjalankan routing RIP memiliki beberapa jalur untuk menjangkau remote network.

Baca juga : Tutorial konfigurasi static routing pada router mikrotik

Routing RIP dibagi menjadi 3 jenis, diantaranya yaitu :

#1. RIPv1
Merupakan jenis routing protocol yang bersifat classfull, dalam proses routing update, routing protocol ini hanya akan mengirimkan informasi network addressnya saja tanpa menyertakan informasi subnet masknya. Hal inilah yang menyebabkan RIPv1 tidak cocok diterapkan pada jaringan yang sudah menggunakan VLSM (Variable Length Subnet Mask).

Router yang menjalankan RIPv1 akan mengirimkan routing update ke router tetangganya (neighbour) dengan cara broadcast. Dari segi keamanan, RIPv1 belum dilengkapi dengan fitur authentication sehingga menyebabkan proses pertukaran routing update kurang aman.

#2. RIPv2
RIPv2 adalah penyempurnaan dari RIPv1, algoritma dan metric yang digunakan keduanya masih sama, yang membedakan adalah RIPv2 merupakan routing protocol yang bersifat classless (cocok digunakan pada jaringan yang menerapkan VLSM) dan proses pengiriman routing update dilakukan dengan cara multicast.

Selain itu, RIPv2 sudah dilengkapi dengan fitur authentication yang bisa digunakan agar proses routing update menjadi lebih aman.

#3. RIPng
RIPng (RIP Next Generation) adalah routing RIP yang hanya digunakan pada jaringan yang sudah menggunakan pengalamatan IPv6.

Konfigurasi Dynamic Routing RIP Pada Mikrotik

Dari penjelasan singkat di atas, saya harap sobat dapat memahami apa itu routing RIP, sekarang kita lanjut ke proses konfigurasinya. Di dalam artikel ini saya hanya akan menjelaskan proses konfigurasi routing RIPv2 pada router mikrotik, untuk RIPv1 sudah jarang sekali digunakan jadi saya rasa tidak terlalu penting (lagipula cara konfigurasinya sama saja).

Pada tutorial ini saya menggunakan topologi jaringan seperti gambar di bawah, tujuan penggunaan routing RIP yaitu untuk menghubungkan 2 network yang berbeda, yaitu network yang berada di bawah router R1 dan router R2.
Tutorial Konfigurasi Routing RIP Pada Router Mikrotik
Pertama, kita harus mengkonfigurasi IP Address pada masing-masing interface router R1 dan R2.
[admin@R1] > /ip address add address=10.10.10.1/30 interface=ether1
[admin@R1] > /ip address add address=192.168.1.1/24 interface=ether2

[admin@R2] > /ip address add address=10.10.10.2/30 interface=ether1
[admin@R2] > /ip address add address=192.168.2.1/24 interface=ether2
Selain interface pada router, interface pada PC-1 dan PC-2 juga harus dikonfigurasi IP Address agar bisa terhubung ke gateway.

Dengan konfigurasi di atas, PC-1 dan PC-2 sudah bisa ping reply ke gateway-nya masing-masing. Namun, PC-1 belum bisa menjangkau PC-2 begitu juga sebaliknya, ini karena PC-1 dan PC-2 berada pada network yang berbeda, untuk menghubungkan keduanya maka harus dilakukan routing.

Langkah-langkah konfigurasi routing RIP cukup simple, kita hanya perlu mengaktifkan protokol routing pada masing-masing interface router yang saling terhubung, kemudian mengadvertise network.

[admin@R1] > /routing rip interface add interface=ether1 send=v2 receive=v2
[admin@R1] > /routing rip network add network=10.10.10.0/30
[admin@R1] > /routing rip network add network=192.168.1.0/24

[admin@R2] > /routing rip interface add interface=ether1 send=v2 receive=v2
[admin@R2] > /routing rip network add network=10.10.10.0/30
[admin@R2] > /routing rip network add network=192.168.2.0/24 
Berikut tabel routing pada masing-masing router setelah routing RIP berhasil dikonfigurasi.
[admin@R1] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.1      ether1                    0
 1 ADC  192.168.1.0/24     192.168.1.1     ether2                    0
 2 ADr  192.168.2.0/24                     10.10.10.2              120

[admin@R2] > /ip route print 
Flags: X - disabled, A - active, D - dynamic, 
C - connect, S - static, r - rip, b - bgp, o - ospf, m - mme, 
B - blackhole, U - unreachable, P - prohibit 
 #      DST-ADDRESS        PREF-SRC        GATEWAY            DISTANCE
 0 ADC  10.10.10.0/30      10.10.10.2      ether1                    0
 1 ADr  192.168.1.0/24                     10.10.10.1              120
 2 ADC  192.168.2.0/24     192.168.2.1     ether2                    0
Dari tabel routing router R1 dan R2 di atas, bisa dilihat bahwa ada salah satu entri routing yang memiliki flag ADr yang berarti entri routing tersebut dihasilkan oleh routing RIP secara dynamic, dan entri routing tersebut statusnya aktif.

Konfigurasi Routing RIP Dengan Authentication

Seperti yang sudah dibahas di atas, RIPv2 sudah dilengkapi dengan fitur authentication agar proses routing update menjadi lebih secure, berikut cara konfigurasi RIPv2 dengan authentication pada router mikrotik.
[admin@R1] > /routing rip interface add interface=ether1 send=v2 receive=v2 authentication=md5 authentication-key=dodiventuraz.net    
[admin@R1] > /routing rip network add network=10.10.10.0/30 
[admin@R1] > /routing rip network add network=192.168.1.0/24

[admin@R2] > /routing rip interface add interface=ether1 send=v2 receive=v2 authentication=md5 authentication-key=dodiventuraz.net
[admin@R2] > /routing rip network add network=10.10.10.0/30
[admin@R2] > /routing rip network add network=192.168.2.0/24 
Sampai disini proses konfigurasi routing RIP pada router mikrotik sudah selesai.

Untuk menguji apakah konfigurasi sudah berhasil atau belum, coba lakukan test ping dari PC-1 ke PC-2 dan sebaliknya, jika hasilnya ping reply maka konfigurasi sudah berhasil.

Update !
Apabila kita menggunakan 2 teknik routing yang berbeda dalam 1 jaringan, misalnya static routing dengan RIP, maka kita bisa menggabungkan kedua teknik routing yang berbeda tersebut agar dapat saling berkomunikasi dengan cara mengkonfigurasi redistribute static routing ke dalam routing RIP.

Tutorialnya bisa sobat baca disini : Tutorial redistribute static routing pada routing RIP.

Sekian tutorial singkat kali ini, semoga bermanfaat dan terimakasih.

Subscribe to receive free email updates: