Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik - OSPF (Open Shortest Path First) adalah salah satu routing protocol dynamic yang termasuk ke dalam kategori Interior Gateway Protocol (IGP). Routing protokol OSPF adalah routing protokol link state yang memiliki kemampuan lebih baik dibanding routing protocol distance vector, misalnya RIP.

Dalam penentuan jalur terbaik untuk mencapai network yang dituju, OSPF menggunakan algoritma djikstra dan cost sebagai metricnya, dikarenakan routing protokol ini merupakan link state routing protokol, maka routing OSFP memiliki pengetahuan yang lengkap mengenai topologi jaringan, hal ini karena router yang menjalankan routing OSPF dapat mengetahui status link dari neighbor router.

Pada artikel sebelumnya saya sudah membahas tutorial konfigurasi routing OSPF Single Area pada router mikrotik, saya sarankan sobat mempelajarinya terlebih dahulu sebelum mempelajari materi kali ini, tujuannya agar sobat memahami konsep dan cara konfigurasi routing OSPF pada router mikrotik di dalam jaringan yang menerapkan skema single area.

Seperti yang sudah saya singgung di artikel sebelumnya bahwa routing OSPF ini merupakan routing protocol yang sangat cocok diterapkan pada jaringan skala menengah hingga jaringan dengan skala besar, untuk jaringan skala besar kita bisa menerapkan konsep hirarki routing, dimana kita bisa memecah jaringan menjadi beberapa area yang berbeda.

Tujuannya agar flooding LSA tidak terlalu besar ketika ada perubahan dalam jaringan yang menerapkan routing protokol OSPF, dengan adanya pembagian area, maka LSA hanya akan diflood ke router-router yang berada dalam satu area yang sama.

Cara Konfigurasi Routing OSPF Multi Area

Dikarenakan materi yang akan kita pelajari kali ini yaitu routing OSPF Multi Area, maka penggunaan routernya pun sedikit lebih banyak dibandingkan dengan artikel sebelumnya.

Sobat bisa melihat contoh topologi di bawah, bisa dilihat bahwa terdapat 5 buah router dengan total 8 network yang berbeda, kita akan belajar mengkonfigurasikannya agar semua network yang ada dapat terhubung satu sama lain.

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Dari contoh topologi di atas, terdapat 3 area yang berbeda yaitu area 0 (backbone area), area 1 dan juga area 2. Sebelum lanjut ke tahap konfigurasi, saya akan menjelaskan posisi masing-masing router yang ada pada topologi di atas, yaitu sebagai berikut.

  • Router R1 : Bertugas sebagai ASBR (Autonomous System Boundary Router), yaitu router yang terhubung ke jaringan luar (internet), router ASBR adalah router yang biasanya menjalankan 2 atau lebih routing protokol secara bersamaan.
  • Router R2 dan R3 : Bertugas sebagai ABR (Area Border Router), yaitu router-router yang berada di dalam 2 area sekaligus, dari contoh topologi di atas bisa dilihat bahwa Router R2 berada di dalam area backbone dan juga berada di dalam area 1. Sedangkan Router R3 berada di dalam area backbone dan area 2.
  • Router R4 dan R5 : Bertugas sebagai IR (Internal Router), yaitu router-router yang hanya berada di dalam 1 regular area saja (non-backbone area), router-router ini tidak terhubung secara langsung ke dalam area backbone melainkan melalui perantara router ABR.


Konfigurasi IP Address

Seperti biasa, kita harus melakukan konfigurasi IP Address pada masing-masing interface router terlebih dahulu, selain IP Address pada interface ethernet, juga tambahkan IP Address pada interface loopback yang akan digunakan sebagai router-id masing-masing router.

Router R1
[admin@R1] > /interface bridge add name=loopback
[admin@R1] > /ip address add address=10.1.1.1/32 interface=loopback 
[admin@R1] > /ip address add address=172.20.0.1/30 interface=ether2
[admin@R1] > /ip address add address=172.20.0.5/30 interface=ether3

Router R2
[admin@R2] > /interface bridge add name=loopback
[admin@R2] > /ip address add address=10.2.2.2/32 interface=loopback 
[admin@R2] > /ip address add address=172.20.0.2/30 interface=ether1
[admin@R2] > /ip address add address=192.168.100.1/30 interface=ether2

Router R3
[admin@R3] > /interface bridge add name=loopback
[admin@R3] > /ip address add address=10.3.3.3/32 interface=loopback 
[admin@R3] > /ip address add address=172.20.0.6/30 interface=ether1
[admin@R3] > /ip address add address=192.168.200.1/30 interface=ether2

Router R4
[admin@R4] > /interface bridge add name=loopback
[admin@R4] > /ip address add address=10.4.4.4/32 interface=loopback 
[admin@R4] > /ip address add address=192.168.100.2/30 interface=ether1
[admin@R4] > /ip address add address=192.168.1.1/24 interface=ether2
[admin@R4] > /ip address add address=192.168.2.1/24 interface=ether3

Router R5
[admin@R5] > /interface bridge add name=loopback
[admin@R5] > /ip address add address=10.5.5.5/32 interface=loopback 
[admin@R5] > /ip address add address=192.168.200.2/30 interface=ether1
[admin@R5] > /ip address add address=192.168.3.1/24 interface=ether2
[admin@R5] > /ip address add address=192.168.4.1/24 interface=ether3

Mengaktifkan Routing OSPF Pada Interface Router

Jika IP Address sudah dikonfigurasi, sekarang kita aktifkan routing OSPF pada masing-masing interface router, tidak semua interface diaktifkan melainkan hanya interface yang menghubungkan antar router saja.

Router R1
[admin@R1] > /routing ospf interface add interface=ether2
[admin@R1] > /routing ospf interface add interface=ether3

Router R2
[admin@R2] > /routing ospf interface add interface=ether1
[admin@R2] > /routing ospf interface add interface=ether2

Router R3
[admin@R3] > /routing ospf interface add interface=ether1
[admin@R3] > /routing ospf interface add interface=ether2

Router R4
[admin@R4] > /routing ospf interface add interface=ether1

Router R5
[admin@R5] > /routing ospf interface add interface=ether1

Konfigurasi Router ID

Setelah mengaktifkan protocol routing OSPF pada masing-masing interface router, hal selanjutnya yang perlu dilakukan yaitu mengkonfigurasi Router ID, Router ID ini sangat penting dalam proses penentuan DR (Designed Router) maupun BDR (Backup Designed Router).

Format penulisan Router ID sama halnya dengan format penulisan IP Address, jika tidak ditentukan secara manual maka router akan menggunakan salah satu IP Address yang ada pada interface router, jika terdapat beberapa IP Address pada interface router, maka router akan mengambil IP Address dengan nilai tertinggi sebagai Router ID-nya.

Router R1
[admin@R1] > /routing ospf instance set 0 router-id=10.1.1.1

Router R2
[admin@R2] > /routing ospf instance set 0 router-id=10.2.2.2

Router R3
[admin@R3] > /routing ospf instance set 0 router-id=10.3.3.3   

Router R4
[admin@R4] > /routing ospf instance set 0 router-id=10.4.4.4 

Router R5
[admin@R5] > /routing ospf instance set 0 router-id=10.5.5.5

Menambahkan Regular Area (Non-Backbone Area)

Jika pada routing OSPF Single Area, setelah melakukan konfigurasi router-id pada masing-masing router, kita sudah bisa melakukan advertise network agar network yang ada pada sebuah router bisa dikenali oleh router lain melalui proses pertukaran routing update.

Namun pada OSPF Multi Area ada 1 tambahan konfigurasi lagi, yaitu membuat regular area (non-backbone area) pada router yang bertugas sebagai ABR (Area Border Router) dan juga IR (Internal Router).

Dari topologi di atas, terdapat dua router ABR yaitu R2 dan R3 dan dua buah router yang bertugas sebagai IR yaitu router R4 dan R5, sehingga kita perlu membuat regular area pada keempat router tersebut.

Router R2
[admin@R2] > /routing ospf area add name=area1 area-id=1.1.1.1

Router R3
[admin@R3] > /routing ospf area add name=area2 area-id=2.2.2.2

Router R4
[admin@R4] > /routing ospf area add name=area1 area-id=1.1.1.1

Router R5
[admin@R5] > /routing ospf area add name=area2 area-id=2.2.2.2

Advertise Network

Terakhir yaitu advertise network pada masing-masing router, dalam proses advertise network ini sobat harus teliti jangan sampai tertukar, pastikan network diadvertise ke dalam area yang seharusnya.

Router R1
[admin@R1] > /routing ospf network add network=172.20.0.0/30 area=backbone 
[admin@R1] > /routing ospf network add network=172.20.0.4/30 area=backbone 

Router R2
[admin@R2] > /routing ospf network add network=172.20.0.0/30 area=backbone 
[admin@R2] > /routing ospf network add network=192.168.100.0/30 area=area1 

Router R3
[admin@R3] > /routing ospf network add network=172.20.0.4/30 area=backbone 
[admin@R3] > /routing ospf network add network=192.168.200.0/30 area=area2 

Router R4
[admin@R4] > /routing ospf network add network=192.168.100.0/30 area=area1 
[admin@R4] > /routing ospf network add network=192.168.1.0/24 area=area1 
[admin@R4] > /routing ospf network add network=192.168.2.0/24 area=area1 

Router R5
[admin@R5] > /routing ospf network add network=192.168.200.0/30 area=area2 
[admin@R5] > /routing ospf network add network=192.168.3.0/24 area=area2 
[admin@R5] > /routing ospf network add network=192.168.4.0/24 area=area2 

Sampai disini konfigurasi routing OSFP Multi Area sudah selesai, untuk memastikan semua router sudah mencapai convergence, sobat bisa mengecek tabel routing pada masing-masing router, pastikan di dalam tabel routing sudah ada entri route dynamic dengan label ADo (Active, Dynamic, OSPF) seperti ini.

Tabel Routing Router R1

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Tabel Routing Router R2

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Tabel Routing Router R3

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Tabel Routing Router R4

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Tabel Routing Router R5

Tutorial Konfigurasi Routing OSPF Multi Area di Mikrotik

Pengujian

Hasil akhir dari semua konfigurasi yang sudah kita lakukan tentu saja pengujian, tujuannya untuk memastikan semua network sudah bisa terkoneksi dan dapat saling berkomunikasi, sebelumnya pastikan PC-1, PC-2, PC-3, PC-4 sudah dikonfigurasi IP Address.

Kemudian lakukan test ping antar PC yang berbeda network, harusnya sudah berhasil ping reply, jika masih unreachable silahkan cek kembali konfigurasi routing OSPFnya. Demikian tutorial kali ini, semoga bermanfaat dan terima kasih.

Berlangganan update artikel terbaru via email:

Iklan Atas Artikel

Iklan Tengah Artikel 1

Iklan Tengah Artikel 2

Iklan Bawah Artikel